View Issue Details

IDProjectCategoryView StatusLast Update
0001530Industrial-Craft²general / otherpublic2015-02-17 11:47
ReporterabdullamuAssigned ToPlayer 
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Product VersionBuilds for MC 1.7.10 
Target VersionFixed in Version 
Summary0001530: the name of item doesnt show but instead shows as e.g ic2.generatorSolidFuel
Descriptionall the name after updating to latest ic2 doesnt show even in nei search only shows ic2.itemName.gui and so one all no exception
TagsNo tags attached.
Minecraft Version

Activities

Chocohead

2015-02-01 23:25

developer   ~0003709

What other mods do you have installed? Have you changed the language?

abdullamu

2015-02-02 12:42

reporter   ~0003710

no i have not changed the language i use english as always ,i use direwolf20 1.7.10 with all mods updated to latest .

Chocohead

2015-02-02 17:16

developer   ~0003711

Try changing to a different version of English. There __may__ be a bug in the en_US lang file, but I don't know if that's what's broken your game.

Indoorsman

2015-02-02 18:18

reporter   ~0003712

Last edited: 2015-02-02 18:18

View 2 revisions

I'm also experiencing this issue with all ic2 related strings... in NEI, in WAILA, in the actual ic2 machine GUI -- all strings show the localization string name rather than the actual value (here's an example http://i.imgur.com/QCBpUe7.png)

(Tried switching my language to a few others and it didn't fix it)

abdullamu

2015-02-02 18:30

reporter   ~0003713

alright i dont know if that wha u ment by different lang i changed minecraft doesthat what u mean if thats what u mean it didnt help i tried uk and spanish but nothing changed

Indoorsman

2015-02-02 18:42

reporter   ~0003714

Last edited: 2015-02-02 18:46

View 2 revisions

I removed every mod except IC2 and that fixed the issue.. I am going to keep adding things back until I find out what is causing the problem.

Chocohead

2015-02-02 18:53

developer   ~0003715

That'd be the best thing to do at this point.

Indoorsman

2015-02-02 19:23

reporter   ~0003716

Last edited: 2015-02-02 19:44

View 2 revisions

It starts happening again when MineFactoryReloaded-[1.7.10]2.8.0RC6-45 is re-added. So, I imagine the problem is coming from MFR or CoFHCore (Though I added CoFHCore before MFR and it didn't cause the problem on it's own so perhaps something MFR does in its "MFR Compat: IC2" sub mod is to blame)

I've created an issue on MFR's github issue board.

Chocohead

2015-02-03 12:51

developer   ~0003720

Try updating to latest IC2, that might/should fix it.

abdullamu

2015-02-03 17:06

reporter   ~0003721

unfortunately it didnt fix it

Chocohead

2015-02-03 18:06

developer   ~0003722

Hmmmm. Is it definitely MFR doing it, since I can't see anything else that could be causing it at this point.

Player

2015-02-05 02:50

administrator   ~0003725

https://github.com/CoFH/CoFHCore/commit/72fa8fbd9a9487523959b7b02df98fb4d280629e breaks IC2's localization, we're working on it.

Issue History

Date Modified Username Field Change
2015-02-01 21:11 abdullamu New Issue
2015-02-01 23:25 Chocohead Note Added: 0003709
2015-02-02 12:42 abdullamu Note Added: 0003710
2015-02-02 17:16 Chocohead Note Added: 0003711
2015-02-02 18:18 Indoorsman Note Added: 0003712
2015-02-02 18:18 Indoorsman Note Edited: 0003712 View Revisions
2015-02-02 18:30 abdullamu Note Added: 0003713
2015-02-02 18:42 Indoorsman Note Added: 0003714
2015-02-02 18:46 Indoorsman Note Edited: 0003714 View Revisions
2015-02-02 18:53 Chocohead Note Added: 0003715
2015-02-02 19:23 Indoorsman Note Added: 0003716
2015-02-02 19:44 Indoorsman Note Edited: 0003716 View Revisions
2015-02-03 12:51 Chocohead Note Added: 0003720
2015-02-03 17:06 abdullamu Note Added: 0003721
2015-02-03 18:06 Chocohead Note Added: 0003722
2015-02-05 02:50 Player Note Added: 0003725
2015-02-17 11:47 Player Status new => resolved
2015-02-17 11:47 Player Resolution open => fixed
2015-02-17 11:47 Player Assigned To => Player