View Issue Details

IDProjectCategoryView StatusLast Update
0001964Industrial-Craft²crossmod-compatibility / submodules / APIpublic2016-08-13 15:30
ReporterEmpyreanAssigned To 
PrioritynormalSeveritycrashReproducibilityalways
Status newResolutionopen 
Product Version 
Target VersionFixed in Version 
Summary0001964: API Crash when updating AbyssalCraft and increasing forge version to 2046
DescriptionStill getting some client crashes not sure if it is IC2 related but the stack trace does report IC2 but i believe its more a machine power craft issue relating to the API

This seems to be client side only and seems only happening while we have machine power craft mod installed on the client. Do not know why its not affecting the server.

Mod Dev for machine power craft is difficult to deal with in regards to these errors

https://gist.github.com/Stuart74/cd90cfe0f0f52c2b9316c0a12ae18f9d [^]
Steps To ReproduceClient side Crash Only

Start client
Crashes about 3/4 into loading the pack
Additional InformationServer does not crash and loads fine it is only client side only and only when i update to a higher forge version than 2014 and updating AbyssalCraft.

Really not sure whats triggering it but seems its IC2 and machine power craft seems to be the API it keeps referring to.
TagsNo tags attached.
Minecraft Version1.10.2

Activities

Empyrean

2016-08-10 10:12

reporter   ~0004692

Current Forge Version is 2014
IC2 Build 37

Chocohead

2016-08-13 15:30

developer   ~0004701

If updating AbyssalCraft causes it then it's down to it adding a smelting recipe that has a null output.

Issue History

Date Modified Username Field Change
2016-08-10 10:08 Empyrean New Issue
2016-08-10 10:12 Empyrean Note Added: 0004692
2016-08-13 15:30 Chocohead Note Added: 0004701