View Issue Details

IDProjectCategoryView StatusLast Update
0002045Industrial-Craft²machinespublic2016-11-29 15:07
ReporterTerpoAssigned ToChocohead 
PrioritylowSeverityminorReproducibilityunable to reproduce
Status resolvedResolutionno change required 
Product Version 
Target VersionFixed in VersionBuilds for MC 1.10.x 
Summary0002045: Canning Machine + EnderIO Ender Fluid Conduit crash (NPE)
DescriptionA player of our server crashed it last night when trying to connect a Ender Fluid Conduit to a Solid/Fluid Canning Machine.

I was unable to reproduce it in a SP instance, after resetting the region file on the server. Server was not able to start anymore after that crash.

The setup was a Solid/Fluid Canning Machine with pulling and ejecting upgrades and additional Ender Fluid Conduits. My member told me that the server crashed when he switched the Conduit Connector for extract to "Redstone ignore".
Additional Informationlog -> http://pastebin.com/P1Uew8sV
MC 1.10.2
Forge 0002122
EnderCore-1.10.2-0.4.1.58-beta.jar
EnderIO-1.10.2-3.0.1.127_beta.jar
industrialcraft-2-2.6.100-ex110.jar

TagsNo tags attached.
Minecraft Version1.10.2

Relationships

duplicate of 0002042 closedChocohead crash 1.10.2, 2-2.6.111-ex110 mek tank + canning with fluid import upgrade 

Activities

Chocohead

2016-11-28 20:35

developer   ~0004895

Last edited: 2016-11-28 20:35

View 2 revisions

Try with IC2 2.6.112+, it should make the crash more useful.

Terpo

2016-11-29 13:34

reporter   ~0004896

hm.... I did a backup of the crashy world yesterday to test it out. Now I'm using industrialcraft-2-2.6.120-ex110 and I can not get it to crash again. After teleporting to the block I can show you the setup, but no way to reproduce atm.

http://terpo.org/blog/upload/mc/bugs/2016-11-29_14.31.50.png
http://terpo.org/blog/upload/mc/bugs/2016-11-29_14.31.56.png

Yesterday, when I tried it in SP, I was not told that there is a Mekanism tank involved and as we can see in 0002042 it may was caused by the same problem.

Chocohead

2016-11-29 15:06

developer   ~0004898

Good that it's not something else.

https://github.com/aidancbrady/Mekanism/commit/459cdc67e87dac87579c43ef52c791ce367cbe70 Fixed the bug within Mekanism, so it should behave itself as of Mekanism 9.2.1.295

Issue History

Date Modified Username Field Change
2016-11-28 19:12 Terpo New Issue
2016-11-28 20:35 Chocohead Note Added: 0004895
2016-11-28 20:35 Chocohead Note Edited: 0004895 View Revisions
2016-11-28 20:35 Chocohead Relationship added related to 0002042
2016-11-28 20:35 Chocohead Assigned To => Chocohead
2016-11-28 20:35 Chocohead Status new => feedback
2016-11-29 13:34 Terpo Note Added: 0004896
2016-11-29 13:34 Terpo Status feedback => assigned
2016-11-29 15:06 Chocohead Note Added: 0004898
2016-11-29 15:06 Chocohead Relationship replaced duplicate of 0002042
2016-11-29 15:06 Chocohead Status assigned => resolved
2016-11-29 15:06 Chocohead Fixed in Version => Builds for MC 1.10.x
2016-11-29 15:06 Chocohead Resolution open => no change required