View Issue Details

IDProjectCategoryView StatusLast Update
0002422Industrial-Craft²machinespublic2018-10-09 14:43
ReporterAtomicWaffle14Assigned ToChocohead 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in VersionBuilds for MC 1.12.x 
Summary0002422: Turbine Rotors don't show when injected with Hoppers or pipes
DescriptionWhen injecting a turbine rotor into a Wind Turbine or Water Turbine block using a hopper or pipe, the 3d turbine rotor model does not render. It will render when you open the Turbine block GUI, or when reloading the game. It seems like the rendering of the blade is linked to the chunk loading or the GUI being opened.
Steps To Reproduce1) Take a hopper (or an item transport pipe from another mod) and point it into a Wind/water Turbine block.
2) Place a turbine blade into the hopper.
3) Notice how the blade goes into the block, and the block will still function properly. However, the rotor will not render unless the chunk is reloaded or the GUI is opened.
Tags1.12.2, Turbine
Minecraft Version1.12.2

Activities

Chocohead

2018-10-09 14:43

developer   ~0005808

Indeed they do, wasn't automatically sending server side rotor changes. Fixed in IC2 2.8.101

Issue History

Date Modified Username Field Change
2018-09-27 19:19 AtomicWaffle14 New Issue
2018-09-27 19:19 AtomicWaffle14 Tag Attached: 1.12.2
2018-09-27 19:19 AtomicWaffle14 Tag Attached: Turbine
2018-10-09 14:43 Chocohead Assigned To => Chocohead
2018-10-09 14:43 Chocohead Status new => resolved
2018-10-09 14:43 Chocohead Resolution open => fixed
2018-10-09 14:43 Chocohead Fixed in Version => Builds for MC 1.12.x
2018-10-09 14:43 Chocohead Note Added: 0005808