View Issue Details

IDProjectCategoryView StatusLast Update
0002554Industrial-Craft²E-Net, cabling, storage/transformer blockspublic2019-06-22 08:41
ReporterTheBudderSlapperAssigned ToChocohead 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionno change required 
PlatformMinecraft LauncherOSWindowsOS VersionWindows 10
Product Version 
Target VersionFixed in Version 
Summary0002554: Game freezes when any kind of cable is attempted to be connected to other cables or machines ( odd behaviour, similar to crash )
DescriptionThe scenario is : Placed filled generator, next to it an extractor and next to the extractor a macerator. Any attempt to connect all three machines using any kind of IC2 Experimental cable causes the connection textures to become rather funky and result in no connection whatsoever, whilst breaking blocks does not provide drops and any kind of interface can not be accessed ( furnace, crafting table, chest etc etc...)

To explain in a different way, it causes the game to freeze as if the player has high ping even though it is singleplayer. Any kind of item which is dropped can not be picked up, any block that is broken does not provide an item drop nor are interfaces accessible. Regarding the cables themselves, the connection textures become funky, they are still the same but they sometimes connect sometimes not. When it is attempted to close the game, the game freezes and minecraft counts it as a crash.

Steps To ReproduceGenerator, any type of machine, connecting the generator with the machines using any kind of IC2 Experimental cable
Additional InformationVersion of IC2 Experimental : 2.8.159-ex112
Version of Forge : forge1.12.2-14.23.5.2838
102 other mods are included as well as loaded, including addons for IC2 Experimental but this bug/glitch happens when using core elements of the mod itself
Tagscables not connecting, eu cable
Minecraft Version1.12.2

Relationships

has duplicate 0002555 closedChocohead Game freezes when any kind of cable is attempted to be connected to other cables or machines ( odd behaviour, similar to crash ) 

Activities

TheBudderSlapper

2019-06-16 23:13

reporter  

Untitled.png (573,855 bytes)

TheBudderSlapper

2019-06-16 23:25

reporter   ~0006032

Forgot to add, some parts of the world do not load aka chunks, items can not be thrown, damage can not be taken. As afore mentioned, the game behaves like the player himself is met with an incredibly high ping, and whenever an exit is attempted the game freezes and crashes

Chocohead

2019-06-18 11:06

developer   ~0006037

This sounds suspiciously like a server thread is crashing. Server side logs would be a big help to see if they shine anything into what is going on, as well as client side if it is crashing due to this.

TheBudderSlapper

2019-06-18 11:49

reporter   ~0006038

The problem is the game does not crash immediately, yet it freezes completely. Mobs are frozen and chunks aren't loading and the game itself does not perceive it as a crash, only when i forcefully close it when it stops responding does the launcher inform me it is a crash without creating a crash log. I tried to find anything of use, mostly the latest logs from .minecraft.

TheBudderSlapper

2019-06-18 11:50

reporter   ~0006039

Here they are

TheBudderSlapper

2019-06-18 11:51

reporter   ~0006040

And the latest debug log i could find, zipped because it's 8MB

debug.zip (790,964 bytes)

TheBudderSlapper

2019-06-18 11:52

reporter  

2019-06-18-1.log.gz (42,118 bytes)

TheBudderSlapper

2019-06-18 11:52

reporter  

debug-1.log.gz (864,375 bytes)

TheBudderSlapper

2019-06-18 11:53

reporter  

2019-06-17-6.log.gz (46,580 bytes)

TheBudderSlapper

2019-06-18 11:53

reporter  

2019-06-17-7.log.gz (130 bytes)

TheBudderSlapper

2019-06-18 11:54

reporter  

latest.zip (47,172 bytes)

TheBudderSlapper

2019-06-18 11:54

reporter  

debug-2.log.gz (868,972 bytes)

Chocohead

2019-06-21 13:23

developer   ~0006043

Hmmmm, any mention of what's going wrong is thin on the ground with those logs. Try with logGridUpdatesVerbose set to true in the debug section of the config file (the section right at the bottom in IC2.ini), then go into the world and try place some cables.

Worth asking too do you have TATW or any other mod that adds RF/FE support to IC2 that could be causing trouble as well?

TheBudderSlapper

2019-06-21 16:13

reporter   ~0006044

Oddly enough, i've managed to solve the problem by removing and replacing all of the mods in my folder one by one. However i am still not sure as to which mod was originally causing this problem, although i suspect it might be either IC2 itself or TechReborn. It is a rather large modpack so i tested the possibilities however i didn't get much information from them. Yes TATW is ineed installed as well as RedstoneFlux. I can not recreate the bug again unfortunately now... It is running fine for me but i am concerned for other players who might encounter this issue.

Chocohead

2019-06-22 00:04

developer   ~0006045

Never seen this before so it definitely sounds like an addon of some sort causing troubles, will keep it in mind if it ever comes up again

TheBudderSlapper

2019-06-22 08:41

reporter   ~0006046

Alright, thanks for the assistance!

Issue History

Date Modified Username Field Change
2019-06-16 23:13 TheBudderSlapper New Issue
2019-06-16 23:13 TheBudderSlapper File Added: Untitled.png
2019-06-16 23:13 TheBudderSlapper Tag Attached: eu cable
2019-06-16 23:13 TheBudderSlapper Tag Attached: cables not connecting
2019-06-16 23:25 TheBudderSlapper Note Added: 0006032
2019-06-18 08:03 TheBudderSlapper Issue cloned: 0002555
2019-06-18 08:03 TheBudderSlapper Relationship added has duplicate 0002555
2019-06-18 11:06 Chocohead Status new => feedback
2019-06-18 11:06 Chocohead Note Added: 0006037
2019-06-18 11:49 TheBudderSlapper Note Added: 0006038
2019-06-18 11:49 TheBudderSlapper Status feedback => new
2019-06-18 11:50 TheBudderSlapper Note Added: 0006039
2019-06-18 11:51 TheBudderSlapper File Added: debug.zip
2019-06-18 11:51 TheBudderSlapper Note Added: 0006040
2019-06-18 11:52 TheBudderSlapper File Added: 2019-06-18-1.log.gz
2019-06-18 11:52 TheBudderSlapper File Added: debug-1.log.gz
2019-06-18 11:53 TheBudderSlapper File Added: 2019-06-17-6.log.gz
2019-06-18 11:53 TheBudderSlapper File Added: 2019-06-17-7.log.gz
2019-06-18 11:54 TheBudderSlapper File Added: latest.zip
2019-06-18 11:54 TheBudderSlapper File Added: debug-2.log.gz
2019-06-21 13:23 Chocohead Status new => feedback
2019-06-21 13:23 Chocohead Note Added: 0006043
2019-06-21 16:13 TheBudderSlapper Note Added: 0006044
2019-06-21 16:13 TheBudderSlapper Status feedback => new
2019-06-22 00:04 Chocohead Assigned To => Chocohead
2019-06-22 00:04 Chocohead Status new => resolved
2019-06-22 00:04 Chocohead Resolution open => no change required
2019-06-22 00:04 Chocohead Note Added: 0006045
2019-06-22 08:41 TheBudderSlapper Note Added: 0006046