View Issue Details

IDProjectCategoryView StatusLast Update
0001663Industrial-Craft²tools / electric itemspublic2015-07-22 14:46
ReporterSanchoAssigned To 
PrioritylowSeveritytrivialReproducibilityalways
Status confirmedResolutionopen 
PlatformPCOSWindows 7OS Version
Product Version 
Target VersionFixed in Version 
Summary0001663: RE-Battery client inventory de-sync (IC2 Version: industrialcraft-2-2.2.755 / Forge Version: 1.7.10-10.13.4.1448)
DescriptionThis is a visual bug only. RE-Batteries can be duplicated into your inventory by shift-left-clicking them from a machine, but disappear as soon as you click on them. I assume your inventory has become de-synchronized with the server.
Steps To Reproduce1) charge several RE-Batteries
2) discharge a battery into any machine
3) shift-left-click the empty battery back into your inventory (at least 1 toolbar slot must be available)
4) repeat steps 2 and 3, except now the battery will go both to your toolbar and your inventory.
5) click on the stack of duplicate batteries and they will disappear.

Please see the attached images.
TagsNo tags attached.
Minecraft Version

Activities

Sancho

2015-07-22 06:23

reporter  

step 1.png (301,049 bytes)

Sancho

2015-07-22 06:23

reporter  

step 2.png (304,346 bytes)

Sancho

2015-07-22 06:27

reporter  

step 3-1.png (303,593 bytes)

Sancho

2015-07-22 06:27

reporter  

step 3-2.png (304,328 bytes)

Sancho

2015-07-22 06:31

reporter  

step 4.png (301,531 bytes)

Sancho

2015-07-22 06:31

reporter  

step 5.png (303,967 bytes)

Chocohead

2015-07-22 13:07

developer   ~0003993

Last edited: 2015-07-22 13:08

View 2 revisions

I replicated it, and found that the produced batteries from shift-clicking have 0/0 EU, while normal ones have 0/10K EU.

They're also unusable and can be stacked with normal ones to convert them into different non-stacking 0/0 EU ones.

Chocohead

2015-07-22 13:07

developer  

2015-07-22_14.05.55.png (122,985 bytes)
2015-07-22_14.05.55.png (122,985 bytes)

Sancho

2015-07-22 14:46

reporter   ~0004000

Worth noting that I've had issues in the past restacking discharged batteries with unused 0/10K batteries. I was unable to reproduce the problem, though.

Issue History

Date Modified Username Field Change
2015-07-22 06:23 Sancho New Issue
2015-07-22 06:23 Sancho File Added: step 1.png
2015-07-22 06:23 Sancho File Added: step 2.png
2015-07-22 06:27 Sancho File Added: step 3-1.png
2015-07-22 06:27 Sancho File Added: step 3-2.png
2015-07-22 06:31 Sancho File Added: step 4.png
2015-07-22 06:31 Sancho File Added: step 5.png
2015-07-22 13:07 Chocohead Note Added: 0003993
2015-07-22 13:07 Chocohead File Added: 2015-07-22_14.05.55.png
2015-07-22 13:08 Chocohead Note Edited: 0003993 View Revisions
2015-07-22 14:38 Aroma1997 Status new => confirmed
2015-07-22 14:46 Sancho Note Added: 0004000