View Issue Details

IDProjectCategoryView StatusLast Update
0002309Industrial-Craft²machinespublic2018-01-27 18:06
ReporterxSparky911xAssigned To 
PriorityhighSeveritymajorReproducibilityalways
Status confirmedResolutionopen 
Product Version 
Target VersionFixed in Version 
Summary0002309: Solid canning machine deleting completed nuclear fuel rods after machine full
DescriptionI have an automated system setup to fill fuel rods with enriched uranium. Once it hits 64 in the output slot, and has no where else to go I would expect the empty fuel rods to start to stack on the input side of the solid canning machine but they still appear to fill with enriched uranium (the arrow is moving in the GUI) and then just disappear. The output stack size still remaining at 64. Who knows how much uranium fuel rods I have deleted before I found this bug. I disconnected all extracting conduits from the machine and they still disappear. I was using enderIO conduits by the way. I am using version 2.6.252-ex110 in the mod pack Age of Engineering 1.1.2
Steps To Reproducehave 128 enriched uranium on hand. Put a stack in the Solid Canning Machine. Also have 128 empty fuel rods on hand, put a stack into the solid canning machine. wait until output of solid canning machine is full, then put another stack of enriched and fuel rods into the solid canning machine, watch em disappear!
Additional InformationThis does not happen with the Fluid/Solid canning machine. The Solid machine might also be storing the completed items in some kind of an internal memory and only displaying the item stack in the output rather than shutting down the machine when output is full.
TagsNo tags attached.
Minecraft Version1.10.2

Activities

xSparky911x

2018-01-27 09:26

reporter  

2018-01-27_03.00.09.png (374,997 bytes)

xSparky911x

2018-01-27 09:26

reporter  

2018-01-27_03.00.12.png (376,467 bytes)

xSparky911x

2018-01-27 09:26

reporter  

2018-01-27_03.00.14.png (376,498 bytes)

Chocohead

2018-01-27 18:06

developer   ~0005526

It's quite an old bug for 1.10 and below (maybe 1.11, don't think it ever got the patch either), basically the machine has 4 output slots but you can only see 1 of them. If you put something like an ejector upgrade in, it can access all 4 so can get the extra stuff out. It was fixed for 1.12, but apparently the branches haven't been merged since.

Issue History

Date Modified Username Field Change
2018-01-27 09:04 xSparky911x New Issue
2018-01-27 09:26 xSparky911x File Added: 2018-01-27_03.00.09.png
2018-01-27 09:26 xSparky911x File Added: 2018-01-27_03.00.12.png
2018-01-27 09:26 xSparky911x File Added: 2018-01-27_03.00.14.png
2018-01-27 18:06 Chocohead Status new => confirmed
2018-01-27 18:06 Chocohead Note Added: 0005526